Incident with inability to update Power BI reports.
Incident Report for ZENSAI
Postmortem

Description: On April 29th, an incident was observed with the API, leading to an inability to update Power BI reports.

Root Cause Identification and Analysis: The root cause of the incident was identified as an issue with the code changes implemented during the Learn365 new release. Specifically, the problem arose from code changes affecting the QuizQuestionPools endpoint, which was utilized in Power BI reports.

Resolution: To resolve the issue, we promptly fixed the problematic code section related to the QuizQuestionPools endpoint. This fix restored the functionality required for updating Power BI reports.

Remediation Items: As a response to this incident, we are taking the following steps to prevent similar issues in the future:

  1. Improvement of Testing Procedures:
* We are using this incident as an opportunity to enhance our testing procedures.
* More robust testing protocols will be implemented to ensure that code changes do not disrupt critical functionalities.

We apologize for any inconvenience caused and appreciate your patience and understanding during this incident. If you have any further concerns or questions, please do not hesitate to contact our support team.

Posted May 10, 2024 - 12:05 CEST

Resolved
This incident has been resolved.
Posted May 07, 2024 - 13:09 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 30, 2024 - 10:33 CEST
Identified
We have identified the cause of the issue and have prepared a hotfix to address it. This hotfix, scheduled for release on April 30th, will eliminate API errors in the affected regions.
Posted Apr 29, 2024 - 16:08 CEST
Update
We are continuing to investigate this issue.
Posted Apr 29, 2024 - 13:51 CEST
Update
We are continuing to investigate this issue.
Posted Apr 29, 2024 - 13:33 CEST
Investigating
At the moment an incident is observed with API that leads to inability to update Power BI reports.

We apologize for any inconvenience you may have experienced.

We understand how important these services are to your learning management needs and appreciate your patience during this incident.

We are working to determine the cause of this issue and will let you know as soon as we know more.

If you have any additional concerns or questions, please do not hesitate to contact our support team.
Posted Apr 29, 2024 - 13:32 CEST
This incident affected: LMS365 North Europe, LMS365 United States, LMS365 Canada, LMS365 United Kingdom, LMS365 Germany, LMS365 Switzerland, LMS365 Government Community Cloud, LMS365 Government Community Cloud High, and LMS365 for Microsoft Teams.